re = /INVIMA [A-Z0-9-]+/m
str = '<div class="productDescription">NEUROBION 100MG/150MG CAJA X 30 TABLETAS<br><br>Modo de Uso: Vía Oral<br>Componente Activo: Vitamina B1 (Tiamina) Y Vitamina B6 (Piridoxina)<br>INVIMA 2019M-0009578-R1</div>
<div class="productDescription">NEUROBION INYECTABLE X 3 AMPOLLAS<br><br>Modo de Uso: Vía Intramuscular<br>Componente Activo:Vitamina B1 (Tiamina) 100 Mg, Vitamina B6 (Piridoxina) 100 Mg Y Vitamina B12 (Cianocobalamina) 1 Mg. Solucion Inyectable Con Tecnología Doble Camara. <br>INVIMA 2015M-13939-R2<br><img class="" data-src="/arquivos/RX.png?v=636054173313030000" src="/arquivos/RX.png?v=636054173313030000"></div>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end