import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(.*)\\.mkv\\.ass";
final String string = "[FAL]Eromanga_sensei-_-01(1280x720 Hi10P HDTV AAC)[70E7F984].mkv.ass\n"
+ "[FAL]Eromanga_sensei-_-02(1280x720 Hi10P HDTV AAC)[DE189E73].mkv.ass\n"
+ "[FAL]Eromanga_sensei-_-03(1280x720 Hi10P HDTV AAC)[A1E5B711].mkv.ass\n"
+ "[FAL]Eromanga_sensei-_-04(1280x720 Hi10P HDTV AAC)[F521AC93].mkv.ass\n"
+ "[FAL]Eromanga_sensei-_-05(1280x720 Hi10P HDTV AAC)[A776CE16].mkv.ass\n"
+ "[FAL]Eromanga_sensei-_-06(1280x720 Hi10P HDTV AAC)[24244951].mkv.ass\n"
+ "[FAL]Eromanga_sensei-_-07(1280x720 Hi10P HDTV AAC)[DFC32A09].mkv.ass\n"
+ "[FAL]Eromanga_sensei-_-08(1280x720 Hi10P HDTV AAC)[783BDB48].mkv.ass\n"
+ "[FAL]Eromanga_sensei-_-09(1280x720 Hi10P HDTV AAC)[677E4FE9].mkv.ass\n"
+ "[FAL]Eromanga_sensei-_-10(1280x720 Hi10P HDTV AAC)[89B519B2].mkv.ass\n"
+ "[FAL]Eromanga_sensei-_-11(1280x720 Hi10P HDTV AAC)[12B783EA].mkv.ass\n"
+ "[FAL]Eromanga_sensei-_-12(1280x720 Hi10P HDTV AAC)[56ABD770].mkv.ass";
final String subst = "7z rn \"C:\\\\Users\\\\Matheus\\\\crunchyroll\\\\[FAL] Eromanga sensei (.ass).zip\" \"$1\\.mkv.ass\" \"$1.ass\"";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}