using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"GB|GB[\w]{2,}$";
string input = @"BG111111111111";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}