$re = '/[\x0-\x20\\\\"&<>[\]^`{|}~\x7F-\xFF]+/m';
$str = 'октеты 0-32 (0-20 hex), "\\", """, "&", "<", ">", "[", "]", "^", "`", "{", "|", "}", "~", октеты 127-255 (7F-FF hex)';
$subst = "_";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;