$re = '/:[^:]+:(.*)/';
$str = '2016-12-31T18:31:34Z:fadfasads:fdafdaffa';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);