import Foundation
let pattern = #"[_ps][0-9]+"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
result.txt
https://stream9.nava.hu/navahu_bdrm/_definst_/amlst:mnfa-84/manifest_w634869604_ps3854000_pd60000000_qc2Vzc2lkPSZvbXE9dHJ1ZSZucD0mbGI9NTdoN1dqVDg5N2VXVnVLUnhhQk9BYzJmS2JKWSUyQlhudGtNQXhSRWxET3BDc0ttR055T2FlRGJSbFQ5SGQyMzZ6MFpReXpmTVlBSlFMJTBEJTBBbEFxWmlOeFBqQSUzRCUzRCUwRCUwQQ==.mpd
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)