re = /\b\d{2}(?=[A-Z0-9]{4} )[A-Z0-9]*[A-Z][A-Z0-9]*\b/m
str = 'AT exempt acc to ยงยง 4 Nr. 1A UStG iVm 6 USTG
254,49/100L 977,23
159C5F Magnatec St-St 0W-30 D, 20L E4 0,00%
Commodity Code :'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end