use strict;
my $str = 'Requester
letitia.partridge@bayleys.co.nz
To view the completed version, please see the file attached.';
my $regex = qr/Hashim Palliveedu <Hashim.Palliveedu@ltimindtree.com>; Pramod Mogarkar <Pramod.Mogarkar@ltimindtree.com>; Rashmi Agarwal <Rashmi.Agarwal@ltimindtree.com>; Sundarrajan Ganesan <Sundarrajan.Ganesan@ltimindtree.com>; Ganesh Baskar <Ganesh.Baskar@ltimindtree.com>; Rajendra Athalye <Rajendra.Athalye@ltimindtree.com>; Kaustav Banerjee <Kaustav.Banerjee@ltimindtree.com>; Nagesh G N <Nagesh.GN@ltimindtree.com>; Mumtaz Alam <Mumtaz.Alam@ltimindtree.com>; SapanA Shah <SapanA.Shah@ltimindtree.com>; Rajendra Athalye <Rajendra.Athalye@ltimindtree.com>; Rohan Thombre <Rohan.Thombre@ltimindtree.com>; Rohan Thombre <Rohan.Thombre@ltimindtree.com>; Rohan Thombre <Rohan.Thombre@ltimindtree.com>; R Vijaykumar <R.Vijaykumar@ltimindtree.com>; Rohan Thombre <Rohan.Thombre@ltimindtree.com>; Rohan Thombre <Rohan.Thombre@ltimindtree.com>; Rohan Thombre <Rohan.Thombre@ltimindtree.com>; Rohan Thombre <Rohan.Thombre@ltimindtree.com>; Rohan Thombre <Rohan.Thombre@ltimindtree.com>; Shraddha1 Sinha <Shraddha1.Sinha@ltimindtree.com>; Shraddha1 Sinha <Shraddha1.Sinha@ltimindtree.com>; Shraddha1 Sinha <Shraddha1.Sinha@ltimindtree.com>; Shraddha1 Sinha <Shraddha1.Sinha@ltimindtree.com>; Shraddha1 Sinha <Shraddha1.Sinha@ltimindtree.com>; Shraddha1 Sinha <Shraddha1.Sinha@ltimindtree.com>; Shraddha1 Sinha <Shraddha1.Sinha@ltimindtree.com>; Shraddha1 Sinha <Shraddha1.Sinha@ltimindtree.com>; Shraddha1 Sinha <Shraddha1.Sinha@ltimindtree.com>; Shraddha1 Sinha <Shraddha1.Sinha@ltimindtree.com>; Shraddha1 Sinha <Shraddha1.Sinha@ltimindtree.com>; Shraddha1 Sinha <Shraddha1.Sinha@ltimindtree.com>; Shraddha1 Sinha <Shraddha1.Sinha@ltimindtree.com>; Rajendra Athalye <Rajendra.Athalye@ltimindtree.com>; Vamsi Krishna <Vamsi.Krishna@ltimindtree.com>; Ranajoy Ghosh <Ranajoy.Ghosh@ltimindtree.com>; Ranajoy Ghosh <Ranajoy.Ghosh@ltimindtree.com>; Ranajoy Ghosh <Ranajoy.Ghosh@ltimindtree.com>; Lata Kademani <Lata.Kademani@ltimindtree.com>; Mukesh Kumar Saini <Mukesh.Saini@ltimindtree.com>; Mukesh Kumar Saini <Mukesh.Saini@ltimindtree.com>; Santosh Umesh Malimath <Santosh.Malimath@ltimindtree.com>; Salona Pal <Salona.Pal@ltimindtree.com>; Salona Pal <Salona.Pal@ltimindtree.com>; Salona Pal <Salona.Pal@ltimindtree.com>; R Vijaykumar <R.Vijaykumar@ltimindtree.com>; R Vijaykumar <R.Vijaykumar@ltimindtree.com>; Gokula Krishnan <Gokula.Krishnan@ltimindtree.com>; Amit Garg <Amit.Garg1@ltimindtree.com>; Swapnali Garge <Swapnali.Garge@ltimindtree.com>; Pradeep Pillai <Pradeep.Pillai@ltimindtree.com>; Amit Thuse <Amit.Thuse@ltimindtree.com>; Ravi Kumar Venkatappa <Ravi.KumarVenkatappa@ltimindtree.com>; Mahalakshmi Veerabadran <Mahalakshmi.Veerabadran@ltimindtree.com>; Sourav Sen <sourav.sen1@ltimindtree.com>; Rajat Rath <Rajat.Rath@ltimindtree.com>; Rajat Rath <Rajat.Rath@ltimindtree.com>; Anusha Rnair <Anusha.Nair@ltimindtree.com>; Rohit Jain <Rohit.Jain2@ltimindtree.com>; Swapna Sugumar <Swapna.Sugumar@ltimindtree.com>; Swapna Sugumar <Swapna.Sugumar@ltimindtree.com>; Jyotish Talukdar <Jyotish.Talukdar@ltimindtree.com>; Jyotish Talukdar <Jyotish.Talukdar@ltimindtree.com>; Sudeepta Ray <Sudeepta.Ray@ltimindtree.com>; Nisanth Mohanadasan <Nisanth.Mohanadasan@ltimindtree.com>; Nisanth Mohanadasan <Nisanth.Mohanadasan@ltimindtree.com>; Abhideep Chakravarty <Abhideep.Chakravarty@ltimindtree.com>; Nisanth Mohanadasan <Nisanth.Mohanadasan@ltimindtree.com>; Sangram Panda <Sangram.Panda2@ltimindtree.com>; Shirish Jaiswal <Shirish.Jaiswal@ltimindtree.com>; Sandip Motwani <Sandip.Motwani@ltimindtree.com>; Tirtha Ghosh <Tirtha.Ghosh@ltimindtree.com>; Uday Shankar <Uday.Shankar@ltimindtree.com>; Nabyendu Roy <Nabyendu.Roy@ltimindtree.com>; Tirtha Ghosh <Tirtha.Ghosh@ltimindtree.com>; Maneesh Singhal <Maneesh.Singhal@ltimindtree.com>; Vinay Padegaonkar <Vinay.Padegaonkar@ltimindtree.com>/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}