$re = '/-[\s]*(.*?)[\s]*-/';
$str = 'CLR Podcast - Anja Schneider - 16th of January 2012';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);