re = /\bStyle Name:\h*\K\S+/m
str = 'Style Name: Something Style Name: Something Style Name: Something'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end