#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)(?=.*\b([a-z]{1,2}\d+)\b)(?=.*\b(\d+)\b)(?=.*((?:\b[a-z]+\b\s*)+)).+"
Local $sString = "XD079523 ALFRED ROMEO 19830311" & @CRLF & _
"ALFRED BETA GAMMA 19830311 AD929523" & @CRLF & _
"BETA FERNANDEZ AS079523 19830311" & @CRLF & _
"19830311 BETA MAX AS079523" & @CRLF & _
"KK079523 19830311 ANGEL MARINA VINES" & @CRLF & _
"19830121 BX079523 VINCENT EVERHART"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")