import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(000[1-9]|00[1-9]\\d|0[1-9]\\d\\d|100\\d|10[1-9]\\d|1[1-9]\\d{2}|[2-9]\\d{3}|[1-9]\\d{4}|1\\d{5}|2[0-6]\\d{4}|27[0-4]\\d{3}|275[0-6]\\d{2}|2757[0-5]\\d|275760)-(0[1-9]|1[012])-(0[1-9]|[12]\\d|3[01])T(0\\d|1\\d|2[0-4]):(0\\d|[1-5]\\d)(?::(0\\d|[1-5]\\d))?(?:.(00\\d|0[1-9]\\d|[1-9]\\d{2}))?$";
final String string = "2018-06-14T00:00\n\n"
+ "2018-06-14T00:00:12\n\n"
+ "2018-06-14T00:00:12.551\n\n"
+ "Minimum to provide to be valid :\n"
+ "yyyy-MM-ddThh:mm\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}