re = /^(https?:\/\/)?([\da-z\.-]+\.[a-z\.]{2,6}|[\d\.]+)([\/:?=&#]{1}[\da-z\.-]+)*[\/\?]?$/m
str = 'Допустимые адреса
http://www.company.com
https://www.company.com
https://company.com
http://company.com
www.company.com
http://www.company.com/some
https://www.company.com/some
www.company.com/some
http://www.company.com/some%20address
https://www.company.com/some%20address
www.company.com/some%20address
http://www.company.com/?sidebar=buyerDetail
https://www.company.com/?sidebar=buyerDetail
www.company.com/?sidebar=buyerDetail
http://www.company.com/some/sidebar=buyerDetail
https://www.company.com/some/sidebar=buyerDetail
www.company.com/some/sidebar=buyerDetail
Недопустимые адреса
1http://www.company.com/some/sidebar=buyerDetail
1https://www.company.com/some/sidebar=buyerDetail
.http://www.company.com/some/sidebar=buyerDetail
.https://www.company.com/some/sidebar=buyerDetail
.http://www.company.com/some/sidebar=buyerDetail
.https://www.company.com/some/sidebar=buyerDetail
com/some/sidebar=buyerDetail
+=.company.com/some/sidebar=buyerDetail'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end