using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^([a-zA-Z.,-_áéíóúñÁÉÍÓÚÑ()]+[,.]?[ ]?|[a-zA-Z.,-_áéíóúñÁÉÍÓÚÑ()]+['-]?)+$";
string input = @"No acepta más de un espacio por palabra";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}