$re = '/(\/.+?)(२)(.+?\/)/m';
$str = '{{https://www.test.com/events/test-event-२०१८/२०१८-.१-entry-list|caption=test event of २०१८}}{{https://www.test.com/events/test-event-३१/३१-.१-entry-list|caption=test event of ३१}}{{https://www.test.com/events/test-event-१८/१८-.१-entry-list|caption=test event of १८}}';
$subst = "$12$3";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;