$re = '/^[a-zA-Z\'\-\ ]{2,16}$/m';
$str = 'D\'Arcy
Dia-Daro
Mary Kate
J
Jo';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);