#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?=^.{5}$)^a*b*c*d*e*f*g*h*i*j*k*l*m*n*o*p*q*r*s*t*u*v*w*x*y*z*$"
Local $sString = "Valid examples include:" & @CRLF & _
"aaaaa" & @CRLF & _
"abcde" & @CRLF & _
"xxyyz" & @CRLF & _
"ghost" & @CRLF & _
"chips" & @CRLF & _
"demos" & @CRLF & _
"" & @CRLF & _
"Invalid examples include:" & @CRLF & _
"abCde" & @CRLF & _
"xxyyzz" & @CRLF & _
"hgost" & @CRLF & _
"chps"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")