package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^((1[0-9]|[3-9][0-9]|[1-9][0-9][0-9]|[1-4][0-9][0-9][0-9]|5000)(\.[0-9]([0-9])?)?)$`)
var str = `10`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}