import re
regex = re.compile(r"(?<year>\d{4})-(?<month>0[1-9]|1[0-2])-(?<day>0[1-9]|1[0-9]|2[0-9]|3[0-1])T(?<time>(?:[0-1][0-9]|2[0-3]):[0-5][0-9]:[0-5][0-9](?:.\d{3})?)(?<timezone>Z|[\+\-](?:0[1-9]|1[0-2]):(?:00|15|30|45))", flags=re.MULTILINE)
test_str = ("2015-02-07T13:28:17.239+02:00\n"
"2015-02-07T13:28:17.239+02:00\n\n"
"2017-00-01T00:00:00Z")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")