$re = '/Tapper\s*(\d*(?:\.\d+)?)[\s\S]*?M845/m';
$str = '%
N1 ( POSTED FILE NAME - WORKNC POST )
N2 ( INPUT FILE NAME - _6033_Cavity__01.TBA)
N3 (DATE/TIME: Thu Mar 15 06:36:08 2018)
N4 G0 G40 G80 G90 G98
N5 G17
N6 G57H901
N7 G173W0.0
N8 B0.000
N9 (Tapper 0.250000)
N10 T21
N11 M06
N12 S100
N13 M843
N14 G173 W0.0
N15 (- )
N16 ( Tapping )
N17 G0 G90 X-0.0001 Y8.8135
N18 G43 Z10.0632 H21
N19 G01 F500. X-0.0001 Y8.8135
N20 G01 Z9.7163 F500.
N21 G98 G84 X-0.0001 Y8.8135 Z6.0376 R7.6376 E10.
N22 G80 G01 F500.
N23 X-0.0001 Y8.8135 Z9.7163
N24 X-0.0001 Y8.8135 Z9.7163
N25
N26 M845
N27 G91 G28 Z0
N28 G90
N29 G57H901
N30 G173W0.0
N31 B0.000
N32 (Drill 0.005000)
N33 T19
N34 M06
N35 S5000
N36 M3
N37 G173 W0.0
N38 (- )
N39 ( Contour Chamfer )
N40 G0 G90 X-0.0001 Y8.8135
N41 G43 Z9.7163 H19
N42 Z7.6375
N43 G01 Z9.8376 F500.
N44 X-0.0001 Y8.8135 Z10.0632
N45
N46 M05
N47 G91 G28 Z0
N48 G90
N49 G57H901
N50 G173W0.0
N51 B0.000
N52 (Tapper 0.750000)
N53 T21
N54 M06
N55 S100
N56 M843
N57 G173 W0.0
N58 (- )
N59 ( Tapping )
N60 G0 G90 X-0.0001 Y8.8135
N61 G43 Z10.0632 H21
N62 G01 F500. X-0.0001 Y8.8135
N63 G01 Z9.7163 F500.
N64 G98 G84 X-0.0001 Y8.8135 Z6.0376 R7.6376 E10.
N65 G98 G84 X-0.0001 Y10.8135 Z6.0376 R7.6376 E10.
N66 G80 G01 F500.
N67 X-0.0001 Y8.8135 Z9.7163
N68 X-0.0001 Y8.8135 Z9.7163
N69
N70 M845
N71 G91 G28 Z0
N72 G90
N73 M30
%';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);