# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?P<macroName>\[\w+\s)(?#匹配宏名称)|(?P<paramName>\w+(?=\=))(?#匹配参数名称)|(?P<intValue>(?<=\=)\d+)(?#匹配int参数)|(?P<intArrayValue2>(?<=\=)\[\d+,\d+\])(?#匹配长度为2的int数组)|(?P<intArrayValue4>(?<=\=)\[\d+,\d+,\d+,\d+])(?#匹配长度为4的int数组)|(?P<stringValue1>\"[a-zA-Z\._0-9\s]+\")(?#匹配使用双引号的string参数)|(?P<stringValue2>\'[a-zA-Z\._0-9\s]+\')(?#匹配使用单引号的string参数)|(?P<var>(?<=\=)\w+)(?#匹配变量型参数)//gm;t' <<< "//完整代码匹配测试
[sprite file=\"1.png\" index=2 rect=[20,20,800,600] pos=[800,600]][sprite file='2.png' index=2 rect=[0,0,0,0]] //这是注释 abcd
[sprite file='2.png' index=2 target=basic_layer]
//遇到这种情况,利用python取出组的名称,判断字符串格式 endwith
[sprite pos=[x,y]] [sprite pos=[3,4]]"