package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[\d\u09E6-\u09EF]+`)
var str = `1234567890০১২৩৪৫৬৭৮৯
A BCabc!"§$`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}