re = /(?<!https:\/\/|http:\/\/)www\.(\S+)/m
str = 'http://www.google.com
https://www.google.com
www.google.com
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end