package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\[([^\][]*?)ermittelbar([^\][]*)\]`)
var str = `[created ermittelbar]
[ ]was [created ermittelbar]`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}