using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(\h*+[CLXVI]{1,7}\.)\h*(.+)\s*((?:(?!(?1)).*\R?)*)";
string input = @" PROCURADORIA GERAL DO ESTADO
PROCURADORIA TRIBUTÁRIA
EXMO. SR. DR. JUIZ DE DIREITO DA 999ª VARA CÍVEL DA CENTRAL DE DÍVIDA
ATIVA DA COMARCA DE MACAÉ DO ESTADO DO RIO DE JANEIRO
Processo nº 0000000000000000000
Proc. adm. [PGE]: PGE/000.000000/2021
Lorem ipsum dolor sit amet, consectetur adipiscing elit, sed do eiusmod tempor incididunt ut labore et dolore magna aliqua. Amet massa vitae tortor condimentum lacinia quis vel eros donec. Vitae aliquet nec ullamcorper sit amet risus nullam eget. Egestas purus viverra accumsan in. Netus et malesuada fames ac turpis egestas integer eget. Semper feugiat nibh sed pulvinar proin gravida. Condimentum lacinia quis vel eros. Non enim praesent elementum facilisis leo vel fringilla est. Vitae proin sagittis nisl rhoncus mattis. In vitae turpis massa sed.
I. Breve Síntese da Demanda
Lorem ipsum dolor sit amet, consectetur adipiscing elit, sed do eiusmod tempor incididunt ut labore et dolore magna aliqua. Odio aenean sed adipiscing diam donec adipiscing tristique risus nec. Sollicitudin nibh sit amet commodo nulla facilisi. Risus feugiat in ante metus dictum at tempor commodo. Ut pharetra sit amet aliquam id diam maecenas. Pretium viverra suspendisse potenti nullam ac tortor. Enim sit amet venenatis urna. Sagittis purus sit amet volutpat consequat mauris. Ultrices neque ornare aenean euismod elementum. Est velit egestas dui id ornare. Non pulvinar neque laoreet suspendisse interdum consectetur libero. Sed felis eget velit aliquet sagittis id consectetur. Risus ultricies tristique nulla aliquet enim tortor at auctor urna. Odio morbi quis commodo odio aenean sed adipiscing diam. Sed arcu non odio euismod.
Neque laoreet suspendisse interdum consectetur. Nisi vitae suscipit tellus mauris a diam maecenas sed. Sit amet luctus venenatis lectus magna fringilla urna porttitor. Urna neque viverra justo nec. Blandit turpis cursus in hac. Donec ultrices tincidunt arcu non sodales. Neque egestas congue quisque egestas. Libero justo laoreet sit amet. Fermentum iaculis eu non diam phasellus. Hendrerit dolor magna eget est lorem ipsum. Nulla pharetra diam sit amet nisl suscipit adipiscing. At consectetur lorem donec massa sapien faucibus.
II. Bla Bla bla
Lorem ipsum dolor sit amet, consectetur adipiscing elit, sed do eiusmod tempor incididunt ut labore et dolore magna aliqua. Odio aenean sed adipiscing diam donec adipiscing tristique risus nec. Sollicitudin nibh sit amet commodo nulla facilisi. Risus feugiat in ante metus dictum at tempor commodo. Ut pharetra sit amet aliquam id diam maecenas. Pretium viverra suspendisse potenti nullam ac tortor. Enim sit amet venenatis urna. Sagittis purus sit amet volutpat consequat mauris. Ultrices neque ornare aenean euismod elementum. Est velit egestas dui id ornare. Non pulvinar neque laoreet suspendisse interdum consectetur libero. Sed felis eget velit aliquet sagittis id consectetur. Risus ultricies tristique nulla aliquet enim tortor at auctor urna. Odio morbi quis commodo odio aenean sed adipiscing diam. Sed arcu non odio euismod.
Neque laoreet suspendisse interdum consectetur. Nisi vitae suscipit tellus mauris a diam maecenas sed. Sit amet luctus venenatis lectus magna fringilla urna porttitor. Urna neque viverra justo nec. Blandit turpis cursus in hac. Donec ultrices tincidunt arcu non sodales. Neque egestas congue quisque egestas. Libero justo laoreet sit amet. Fermentum iaculis eu non diam phasellus. Hendrerit dolor magna eget est lorem ipsum. Nulla pharetra diam sit amet nisl suscipit adipiscing. At consectetur lorem donec massa sapien faucibus.
III. Do Mérito
Lorem ipsum dolor sit amet, consectetur adipiscing elit, sed do eiusmod tempor incididunt ut labore et dolore magna aliqua. Felis eget velit aliquet sagittis id consectetur purus. Tincidunt dui ut ornare lectus sit amet est placerat. Gravida neque convallis a cras semper. Nullam vehicula ipsum a arcu cursus vitae congue mauris. Mauris commodo quis imperdiet massa tincidunt nunc pulvinar sapien. Facilisis mauris sit amet massa vitae tortor condimentum lacinia quis. In arcu cursus euismod quis viverra nibh cras pulvinar mattis. Malesuada fames ac turpis egestas sed tempus. Nunc consequat interdum varius sit amet mattis vulputate enim. Netus et malesuada fames ac turpis. Odio aenean sed adipiscing diam donec adipiscing tristique. Vulputate mi sit amet mauris commodo quis imperdiet massa. Vestibulum lorem sed risus ultricies. Consectetur adipiscing elit duis tristique sollicitudin nibh sit amet commodo. Faucibus turpis in eu mi bibendum neque egestas. Augue interdum velit euismod in pellentesque massa placerat duis ultricies. Sollicitudin ac orci phasellus egestas tellus.
Tortor vitae purus faucibus ornare. Velit sed ullamcorper morbi tincidunt ornare. At volutpat diam ut venenatis tellus in. Volutpat diam ut venenatis tellus in. Erat nam at lectus urna duis convallis convallis tellus. Egestas quis ipsum suspendisse ultrices gravida dictum fusce ut. Faucibus vitae aliquet nec ullamcorper sit amet risus. Massa massa ultricies mi quis. Velit sed ullamcorper morbi tincidunt. Et malesuada fames ac turpis egestas sed. Pretium lectus quam id leo in. Consequat nisl vel pretium lectus quam id leo in. Morbi tristique senectus et netus et malesuada. Id aliquet risus feugiat in ante metus dictum at tempor. In nulla posuere sollicitudin aliquam. Quam vulputate dignissim suspendisse in est ante in. Ac felis donec et odio pellentesque diam volutpat commodo.
IV. Conclusão
Lorem ipsum dolor sit amet, consectetur adipiscing elit, sed do eiusmod tempor incididunt ut labore et dolore magna aliqua. Felis eget velit aliquet sagittis id consectetur purus. Tincidunt dui ut ornare lectus sit amet est placerat. Gravida neque convallis a cras semper. Nullam vehicula ipsum a arcu cursus vitae congue mauris. Mauris commodo quis imperdiet massa tincidunt nunc pulvinar sapien. Facilisis mauris sit amet massa vitae tortor condimentum lacinia quis. In arcu cursus euismod quis viverra nibh cras pulvinar mattis. Malesuada fames ac turpis egestas sed tempus. Nunc consequat interdum varius sit amet mattis vulputate enim. Netus et malesuada fames ac turpis. Odio aenean sed adipiscing diam donec adipiscing tristique. Vulputate mi sit amet mauris commodo quis imperdiet massa. Vestibulum lorem sed risus ultricies. Consectetur adipiscing elit duis tristique sollicitudin nibh sit amet commodo. Faucibus turpis in eu mi bibendum neque egestas. Augue interdum velit euismod in pellentesque massa placerat duis ultricies. Sollicitudin ac orci phasellus egestas tellus.
Tortor vitae purus faucibus ornare. Velit sed ullamcorper morbi tincidunt ornare. At volutpat diam ut venenatis tellus in. Volutpat diam ut venenatis tellus in. Erat nam at lectus urna duis convallis convallis tellus. Egestas quis ipsum suspendisse ultrices gravida dictum fusce ut. Faucibus vitae aliquet nec ullamcorper sit amet risus. Massa massa ultricies mi quis. Velit sed ullamcorper morbi tincidunt. Et malesuada fames ac turpis egestas sed. Pretium lectus quam id leo in. Consequat nisl vel pretium lectus quam id leo in. Morbi tristique senectus et netus et malesuada. Id aliquet risus feugiat in ante metus dictum at tempor. In nulla posuere sollicitudin aliquam. Quam vulputate dignissim suspendisse in est ante in. Ac felis donec et odio pellentesque diam volutpat commodo.
Rio de Janeiro, 21 de novembro de 2021.
Fulano da Silva Souza
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}