$re = '/ |number: |\([^)]*\)/m';
$str = 'number: 20 (10 30 10 zzz) 40 60';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);