#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)<\s*((?:[\w-]+:)?)node2\b[^>]*>\s*(\w+)\s+(\w+)\s+(\w+)\s+(\w+)\s*<\s*\/\s*\1node2\s*>"
Local $sString = "<NODE1>A1</NODE1>" & @CRLF & _
"<NODE2 id="1234" title="Second node">B1 B2 B3 B4 </ NODE2 >" & @CRLF & _
"< node2>A1 B2 C3 ZZZ4</node2>" & @CRLF & _
"<namespace:node2>A1 A2 A3 A4</namespace:node2>" & @CRLF & _
"< other-namespace:node2 attr = "value"> W X Y Z</other-namespace:node2>" & @CRLF & _
"<NODE3>C1</NODE3>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")