import re
regex = re.compile(r"^https?:\/\/(mobile.)?twitter\.com\/(?:#!\/)?(\w+)\/status(es)?\/(\d+)", flags=re.MULTILINE)
test_str = ("https://twitter.com/AarikaRhodes/status/1488886265332125702\n"
"https://mobile.twitter.com/TimmerFidelity/status/1491862735067430918\n"
"https://foxnews.com")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")