$re = '/^\D(?=\w{5})(?=\d{2})/m';
$str = 'bana12';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);