$re = '/(.*)\h-\h/mu';
$str = 'Here is some more - text. And here is 4 more - The Alchemist';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);