import Foundation
let pattern = #"\b\d+%(?!.*\bDiscount\b)"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .dotMatchesLineSeparators])
let testString = #"""
Lorem ipsum dolor 10% sit amet, consectetur adipiscing elit. Morbi et
feugiat Discount vitae 15% urna. Sed 20% et lorem in dapibus.
Mauris arcu dui, vestibulum eget eros eu, eleifend luctus risus.
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)