re = /^\w*?[a-zA-Z]\w+@[a-z\d\-]+(\.[a-z\d\-]+)*\.[a-z]+\z/i
str = '4412345@gmail.com'
# Print the match result
str.match(re) do |match|
puts match.to_s
end