re = /[a-zA-Z.!#$%&’*+\/=?^_`{|}~-]+@[a-zA-Z0-9-]+(?:\.[a-zA-Z0-9-]+)*/
str = 'hmm12345@gmail.com
woohyeah@gmail.com'
# Print the match result
str.match(re) do |match|
puts match.to_s
end