package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?ms)([A-Z ]+)?$`)
var str = `ABC ABC ABC ABc`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}