$re = '/^(?!\.)(""([^""\r\\\\]|\\\\[""\r\\\\])*""|([-a-z0-9!#$%&\'*+/=?^_`{|}~]|(?<!\.)\.)*)(?<!\.)@[a-z0-9][\w\.-]*[a-z0-9]\.[a-z][a-z\.]*[a-z]$/';
$str = 'Ima.Fool@example.com';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);