$re = '/^[0-9]{7,} Bytes$/';
$str = '5027815 Bytes';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);