$re = '/^[^\/]+\/[^\/].*$|^\/[^\/].*$/mi';
$str = 'http://www.stackoverflow.com
about.html
tutorial1/
tutorial1/2.html
/
/experts/
https://google.com
../
../experts/
../../../
./
./about.html
https://regex101.com
//something
/something
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);