package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?U)\[(.*-.* )*\]`)
var str = `[3-431 a4-2 4-13 ]`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}