#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?:settingsB *=|\G(?!^) *,) *\K[\d.]+"
Local $sString = "settingsA=9, 4.2 " & @CRLF & _
"settingsB=3, 1.5, 9, 2, 4, 6" & @CRLF & _
"settingsC=8, 3, 2.5, 1"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")