re = /(?<!\d)\d+(?=\D*$)/m
str = 'casale-monferrato/incomincia-oggi-roma-l-ultimo-atto-processo-eternit-davanti-corte-cassazione-74506.html'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end