using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[а-я].*(?=<\/a>)";
string input = @"<h3 class=""r""><a href=""https://ru.wikipedia.org/wiki/%D0%9F%D0%B0%D0%B0%D0%BF,_%D0%AD%D0%BD%D0%B4%D0%B5%D0%BB%D1%8C_%D0%90%D0%BB%D1%8C%D1%84%D1%80%D0%B5%D0%B4%D0%BE%D0%B2%D0%B8%D1%87"" ping=""/url?sa=t&source=web&rct=j&url=https://ru.wikipedia.org/wiki/%25D0%259F%25D0%25B0%25D0%25B0%25D0%25BF,_%25D0%25AD%25D0%25BD%25D0%25B4%25D0%25B5%25D0%25BB%25D1%258C_%25D0%2590%25D0%25BB%25D1%258C%25D1%2584%25D1%2580%25D0%25B5%25D0%25B4%25D0%25BE%25D0%25B2%25D0%25B8%25D1%2587&ved=0ahUKEwjiwq_D0I_aAhWmBZoKHddKDIAQFggnMAA"">Паап, Эндель Альфредович — Википедия</a></h3>
<h3 class=""r""><a href=""https://www.youtube.com/watch?v=x_ey1PsMHAc"" ping=""/url?sa=t&source=web&rct=j&url=https://www.youtube.com/watch%3Fv%3Dx_ey1PsMHAc&ved=0ahUKEwjiwq_D0I_aAhWmBZoKHddKDIAQtwIILTAB"">Паап - YouTube</a></h3>
<h3 class=""r""><a href=""http://www.warheroes.ru/hero/hero.asp?Hero_id=20281"" ping=""/url?sa=t&source=web&rct=j&url=http://www.warheroes.ru/hero/hero.asp%3FHero_id%3D20281&ved=0ahUKEwjiwq_D0I_aAhWmBZoKHddKDIAQFggwMAI"">Герой Социалистического Труда Паап Эндель Альфредович ...</a></h3>
<h3 class=""r""><a href=""http://miningwiki.ru/wiki/%D0%9F%D0%B0%D0%B0%D0%BF_%D0%AD%D0%BD%D0%B4%D0%B5%D0%BB%D1%8C_%D0%90%D0%BB%D1%8C%D1%84%D1%80%D0%B5%D0%B4%D0%BE%D0%B2%D0%B8%D1%87"" ping=""/url?sa=t&source=web&rct=j&url=http://miningwiki.ru/wiki/%25D0%259F%25D0%25B0%25D0%25B0%25D0%25BF_%25D0%25AD%25D0%25BD%25D0%25B4%25D0%25B5%25D0%25BB%25D1%258C_%25D0%2590%25D0%25BB%25D1%258C%25D1%2584%25D1%2580%25D0%25B5%25D0%25B4%25D0%25BE%25D0%25B2%25D0%25B8%25D1%2587&ved=0ahUKEwjiwq_D0I_aAhWmBZoKHddKDIAQFgg1MAM"">Паап Эндель Альфредович — MiningWiki — шахтёрская ...</a></h3>
<h3 class=""r""><a href=""https://www.visitestonia.com/ru/%D1%81%D0%B0%D1%84%D0%B0%D1%80%D0%B8-%D1%86%D0%B5%D0%BD%D1%82%D1%80-%D0%BF%D0%B0%D0%B0%D0%BF%D0%B0-%D0%BA%D1%8B%D0%BB%D0%B0%D1%80%D0%B0"" ping=""/url?sa=t&source=web&rct=j&url=https://www.visitestonia.com/ru/%25D1%2581%25D0%25B0%25D1%2584%25D0%25B0%25D1%2580%25D0%25B8-%25D1%2586%25D0%25B5%25D0%25BD%25D1%2582%25D1%2580-%25D0%25BF%25D0%25B0%25D0%25B0%25D0%25BF%25D0%25B0-%25D0%25BA%25D1%258B%25D0%25BB%25D0%25B0%25D1%2580%25D0%25B0&ved=0ahUKEwjiwq_D0I_aAhWmBZoKHddKDIAQFgg7MAQ"">Сафари-центр Паапа Кылара, Эстония - Visit Estonia</a></h3>
<h3 class=""r""><a href=""https://rus.postimees.ee/1367208/endel-paap-ya-chelovek-ne-ishchushchiy-slavy"" ping=""/url?sa=t&source=web&rct=j&url=https://rus.postimees.ee/1367208/endel-paap-ya-chelovek-ne-ishchushchiy-slavy&ved=0ahUKEwjiwq_D0I_aAhWmBZoKHddKDIAQFghSMAs"">Эндель Паап: «Я - человек, не ищущий славы» - Эстония - Rus ...</a></h3>
<h3 class=""r""><a href=""https://rus.postimees.ee/1354564/geroy-socialisticheskogo-truda-endel-paap-stal-pochetnym-grazhdaninom-yyhviskoy-volosti"" ping=""/url?sa=t&source=web&rct=j&url=https://rus.postimees.ee/1354564/geroy-socialisticheskogo-truda-endel-paap-stal-pochetnym-grazhdaninom-yyhviskoy-volosti&ved=0ahUKEwjiwq_D0I_aAhWmBZoKHddKDIAQFghYMAw"">Герой социалистического труда Эндель Паап стал почетным ...</a></h3>
<h3 class=""r""><a href=""http://www.maap.pro/obuchenie/dlya-vypusknikov/paap.html"" ping=""/url?sa=t&source=web&rct=j&url=http://www.maap.pro/obuchenie/dlya-vypusknikov/paap.html&ved=0ahUKEwjiwq_D0I_aAhWmBZoKHddKDIAQFgheMA0"">ПААП - МААП</a></h3>
<h3 class=""r""><a href=""https://ru-ru.facebook.com/public/%D0%98%D1%80%D0%B8%D0%BD%D0%B0-%D0%9F%D0%B0%D0%B0%D0%BF"" ping=""/url?sa=t&source=web&rct=j&url=https://ru-ru.facebook.com/public/%25D0%2598%25D1%2580%25D0%25B8%25D0%25BD%25D0%25B0-%25D0%259F%25D0%25B0%25D0%25B0%25D0%25BF&ved=0ahUKEwjiwq_D0I_aAhWmBZoKHddKDIAQFghjMA4"">Профили по запросу «Ирина Паап» | Facebook</a></h3>
<h3 class=""r""><a href=""https://vesti-ukr.com/Paap-Guje"" ping=""/url?sa=t&source=web&rct=j&url=https://vesti-ukr.com/Paap-Guje&ved=0ahUKEwjiwq_D0I_aAhWmBZoKHddKDIAQFghoMA8"">Паап Гуйе новости и статьи. Читайте все публикации по теме ...</a></h3>
<h3 class=""r""><a href=""http://roapinfo.ru/?page_id=672"" ping=""/url?sa=t&source=web&rct=j&url=http://roapinfo.ru/%3Fpage_id%3D672&ved=0ahUKEwjiwq_D0I_aAhWmBZoKHddKDIAQFghtMBA"">Пермская Ассоциация аналитической психологии (ПААП) | РОАП ...</a></h3>
<h3 class=""r""><a href=""https://ok.ru/sherbet"" ping=""/url?sa=t&source=web&rct=j&url=https://ok.ru/sherbet&ved=0ahUKEwjiwq_D0I_aAhWmBZoKHddKDIAQFghyMBE"">Андрей Паап - Ok</a></h3>
<h3 class=""r""><a href=""https://ok.ru/profile/498124274239"" ping=""/url?sa=t&source=web&rct=j&url=https://ok.ru/profile/498124274239&ved=0ahUKEwjiwq_D0I_aAhWmBZoKHddKDIAQFgh3MBI"">Татьяна Паап</a></h3>";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}