# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(COM-)(ALM\d{1,2}_)(BIT$|BIT\d{3,}$|BIT\D.*|(?!BIT)\D.*)"
test_str = ("COM-ALM2_BIT_1\n"
"COM-ALM2_BIT\n"
"COM-ALM2_AZIrgendwas_1\n"
"COM-ALM3_NameBIT\n"
"COM-ALM3_BITName\n"
"COM-ALM3_Name\n"
"COM-ALM2_BIT1\n"
"COM-ALM2_BIT15\n"
"COM-ALM11_BIT7\n"
"COM-ALM11_BIT11\n"
"OM-ALM_BIT1\n"
"COM-ALM_Name\n"
"COM-ALM11_BIT113\n"
"COM-ALM11_BIT1134")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.