# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"[a-zA-Z0-9\.\|\ \/\:\(\)\<\>\=\-\#\"\,]*\ \(Transaction\ ID\ ([0-9]*)\)[a-zA-Z0-9\.\|\ \/\:\(\)\<\>\=\-\#\"\,]*"
test_str = "Transformers: The IDW Collection, Vol. 5 (#82973) stock reduced from 18 to 17.|Order status changed from Failed to Processing.|Authorize.Net CIM Charge Approved: Visa ending in 5991 (expires 06/21) (Transaction ID 60782052346)|Authorize.Net CIM Payment Failed (Status code 2: Error Code: 27 - The transaction has been declined because of an AVS mismatch. The address provided does not match billing address of cardholder. Transaction ID 60782050745) Order status changed from Pending payment to Failed."
subst = "WINNER"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.