$re = '/(?<!\.)\s{2,}/m';
$str = 'My name is Mohit. Surname is Kumar';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);