$re = '/\"(\d,\d,?\d?)\"/m';
$str = '"2,5"
"2"
"2,5,6"';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);