# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(\d{4}|\d{2})\/(0?[1-9]|1[0-2])\/(0?[1-9]|[12]\d|3[01]), ([AP])M([1-9]|1[0-2]):([0-5]\d) - (.*?): ((?:(?!(?:\d{4}|\d{2})\/(?:0?[1-9]|1[0-2])\/(?:0?[1-9]|[12]\d|3[01]))[\s\S])*)(?=\n|$)"
test_str = ("2012/12/1, AM12:21 - user1: entry1_wasehhjdsaj\n"
"2012/12/2, AM9:42 - user2: entry2_bahbahbah_dsdeead\n"
"2012/12/2, AM9:44 - user3: entry3_Line1_ContdWithFollowingLine_bahbah\n"
"entry3_Line2_ContdWithABoveLine_bahbahbah_erererw\n"
"entry3_Line3_ContdWithABoveLine_bahbahbah_dsff\n"
"2012/12/4, AM11:48 - user7: entry4_bahbahbah_fggf")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.