import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(\\D+)(.+)$";
final String string = "Agent AB 7:00 AM\n"
+ "Agent AB 7:00 AM\n"
+ "Cust XY 8:00 AM\n"
+ "Cust XY 9:00 AM\n"
+ "Agent AB 11:00 AM";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}