use strict;
my $str = 'ChainedQuery elapsed time [90]ms
Elapsed time: 114ms
Elapsed time to get Service pool: 339
Elapsed Time: 69
,took 37ms';
my $regex = qr/\s+[\[]?(\d+)/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}