using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(.+)(?:\/([\w\-\._]+\.js))(?:\?(.+))?";
string input = @"leaflet-0.7.2.js
/leaflet-0.7.2.js
http://leafletjs.com/dist/leaflet.js
https://api.tiles.mapbox.com/mapbox.js/v1.6.3/mapbox.js
http://example.com/path/to/leaflet-0.7.2.js
http://example.com/path/to/mapbox-v1.6.2.js
http://leafletjs.com/dist/leaflet.js?v=123456&hide=true#section
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}