$re = '/(.*)[\r\n]+/m';
$str = 'ABC
CBA
DDD
JKL';
$subst = "$1,";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;